Note utilisateur: 5 / 5

Etoiles activesEtoiles activesEtoiles activesEtoiles activesEtoiles actives
 

 

 

Sous ce nom d'article un peu humoristique se cache un vrai problème...

En effet, par défaut, sous Excel, 14 heures + 15 heures = 5 heures (si, si, essayez, vous verrez)

Pas pratique pour calculer des heures, par exemple, lors de la création d'un planning....

Heureusement, la méthode pour remédier à ce problème est toute simple...

 

 

Jamais plus de 24 heures

Si vous faites une somme avec des heures sous Excel, vous aurez beau trépigner, la somme ne dépassera jamais 24 heures.

Comme je vous le disais en guise d'introduction, pour Excel, 14 heures + 15 heures = 5 heures. 

En réalité, Excel n'est pas si bête que ça : même si le résultat ne se voit pas, Excel cherche à vous dire : 14 heures + 15 heures = 1 jour + 5 heures !

 

001

 

Ce problème est donc très fréquemment par les pauvres chefs d'équipes lorsqu'ils établissent des tableaux de relevés d'heures ou des plannings.

Notez que, pour une fois, la gauche n'y est pour rien : le problème était identique du temps des 39 heures

Nous allons voir comment faire en sorte que 14 h + 15 h = 29 h

 

 

Un exemple pour comprendre

Traçons un petit tableau vite fait. Celui-ci nous permettra de noter nos heures afin de calculer en fin de semaine notre temps de travail (et donc nos heures supplémentaires...)

002

 

 

Mettons les champs de la colonne C au format heure... Pour cela, sélectionnez la totalité de la colonne...

003

 

 

Faites ensuite un clic droit sur l'une des cellules, puis choisissez la ligne "Format de cellule" dans le menu contextuel...

004

 

 

Cliquez sur l'onglet "Nombre", puis choissez la catégorie "Heure"

005

 

 

Sélectionnez ensuite le type "13:30" (HH:MM) dans la liste des types, puis validez par "Ok"

006

 

 

Dans les lignes destinées à calculer le total de mes heures de la semaine, je créé une formule "SOMME".

Dans mon exemple, la formule est =SOMME(C2+C3+C4+C5+C6+C7+C8) ou, plus simplement =SOMME(C2:C8)

007

 

 

Entrez quelques heures pour que le problème vous saute aux yeux...

008

 

 

Arghh ! D'après Excel, je suis encore bien loin des 35 heures !!! J'ai pourtant bien l'impression d'avoir travaillé un peu plus que 2 heures...

Si vous faites le calcul de tête (ou à la CASIO), vous constaterez que vous avez travaillé 50 heures...

En fait, derrière ses airs perdus, Excel tente désespérément de vous dire que vous avez trimé 2 jours + 2 heures...

 

 

Corriger le problème

Pour cela, nous allons modifier le format des cellules comportant les sommes des heures (dans notre exemple, nous allons donc modifier les cellules C9, C17 et C25)

Sélectionnez les cellules, puis retournez sur le menu "Format de cellule" de tout à l'heure

009

 

 

Retournez sur l'onglet "Nombre", puis choisissez "Personnalisée" dans la liste des catégories :

010

 

 

Dans le champ "Type", saisissez le format suivant : [h]:mm

011

 

 

Validez en cliquant sur "Ok" et vous constaterez ensuite que les calculs d'heures sont corrects !

012

 

 

Vous voilà parés vous aussi pour des semaines de 50 heures

 

 

greg

 

 

1000 caractères restants