Note utilisateur: 5 / 5

Etoiles activesEtoiles activesEtoiles activesEtoiles activesEtoiles actives
 

 

 

 

La fonction NB.SI est très pratique : elle permet de compter le nombre de données qui répondent à un critère donné.

Dans ce tutoriel, nous allons apprendre à l'utiliser.

 

Compter le nombre de données selon un critère définit

J'ai un tableau excel qui contient quelques amis.

Dans la colonne B, est indiqué leur mois de naissance.

 

 

Je souhaite savoir combien d'entre eux sont natifs du mois de mai.

Je me positionne dans la cellule B21, et je clique dans le menu "Insertion", puis "Fonction"

 

 

Je recherche la fonction NB.SI et je double-clic sur celle-ci.

 

 

Excel me demande 2 informations :

  • La plage dans laquelle la recherche doit-être effectuée
  • Le critère qui doit être recherché dans cette plage.

 

 

Je peux déterminer ma plage à la main (ma colonne contenant mes mois s'etend des cellules B2 à B19), ou utiliser le sélecteur afin de sélectionner les cellules voulues.

Pour vous habituer à entrer les coordonnées à la main, ce qui vous sera bien pratique si vous travaillez avec des fichiers de milliers de ligne, saissez donc :

B2:B19

 

 

Déterminons à présent le critère qui devra être recherché dans ma plage : le mois de mai. J'indique donc tout simplement "mai", entre guillemets

 

 

Validons notre fonction en cliquant sur "Ok"

 

 

Excel effectue le calcul et m'indique que 5 de mes amis sont nés au mois de mai (et que je serai donc probablement à découvert ce mois-ci ^^ )

 

 

Regardons de plus près la syntaxe de la formule :

=NB.SI(B2:B19;"mai")

La syntaxe de la formule NB.SI est donc :

=NB.SI(plage;critère)

 

 

Compter le nombre de données selon un critère entré dans une cellule

La première méthode que nous avons vue a des critères fixes, déterminés à l'avance.

Si je souhaite rendre ma fonction NB.SI dynamique, ce n'est pas beaucoup plus compliqué.

 

Dans ma cellule B21, je créé une liste déroulante contenant les mois de l'année...

Si vous ne savez pas comment créer une liste déroulante, lisez ce tutoriel

 

 

Je sélectionne ma cellule C21, dans laquelle j'insère une fonction NB.SI, comme tout à l'heure ("Intertion", "Fonction").

Ma plage de recherche n'a pas changée : il s'agit toujours des cellules B2 à B19...

 

 

Je vais déterminer à présent mon critère, qui sera fourni par la sélection du mois dans ma liste.

Je clique sur le sélecteur du critère...

 

 

Puis je sélectionne la cellule B21, qui contient ma liste déroulante...

 

 

Je valide en appuyant sur la touche "Entrée" de mon clavier....

J'aurais tout aussi bien pu entrer "B21" à la main, mais au moins, nous avons vu l'usage du sélecteur :-)

 

 

Je valide les arguments de ma fonction en cliquant sur "OK"...

Je n'ai plus qu'à sélectionner le mois dans ma liste déroulante, pour que la fonction NB.SI compte automatiquement le nombre d'occurences du mois sélectionné....

 

La syntaxe de ma fonction est tout simplement :

=NB.SI(B2:B19;B21)

 

 

 

 

 

1000 caractères restants